Configure a CCC Local Connection

A local CCC connection refers to the connection between two local CEs, that is, two CEs connected to the same PE. Similar to a Layer 2 switch, the PE can switch traffic without the need to set up a static LSP.

Networking Requirements

Figure 1 shows the CE is connected with the PE through a POS interface. The packets are encapsulated in PPP over the link layer.
A local connection is created between CE1 and CE2.
Figure 1 Networking diagram of the local CCC connection

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure basic MPLS capability on PE and enable the MPLS L2VPN.
  2. Create a local connection from CE1 to CE2 on PE. (Because the local CCC connection is duplex, only one connection is needed.)

Data Preparation

To complete the configuration, you need the IP addresses of the interfaces.

Procedure

  1. Configure CE.
    # Configure CE1.
    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] interface pos 1/0/0
    [CE1-Pos1/0/0] ip address 100.1.1.1 24
    [CE1-Pos1/0/0] undo shutdown
    [CE1-Pos1/0/0] quit
    # Configure CE2.
    <HUAWEI> system-view
    [HUAWEI] sysname CE2
    [CE2] interface pos 1/0/0
    [CE2-Pos1/0/0] ip address 100.1.1.2 24
    [CE2-Pos1/0/0] undo shutdown
    [CE2-Pos1/0/0] quit
  2. Configure PE.
    # Configure LSR IDs and enable MPLS and MPLS L2VPN.
    <HUAWEI> system-view
    [HUAWEI] sysname PE
    [PE] interface loopback 1
    [PE-LoopBack1] ip address 1.1.1.9 32
    [PE-LoopBack1] quit
    [PE] mpls lsr-id 1.1.1.9
    [PE] mpls
    [PE-mpls] quit
    [PE] mpls l2vpn
    [PE-l2vpn] quit
    [PE] interface pos 1/0/0
    [PE-Pos1/0/0] undo shutdown
    [PE-Pos1/0/0] quit
    [PE] interface pos 2/0/0
    [PE-Pos2/0/0] undo shutdown
    [PE-Pos2/0/0] quit
    # Create the local connection from CE1 to CE2.
    [PE] ccc ce1-ce2 interface pos 1/0/0 out-interface pos 2/0/0
  3. Verify the configuration.
    After the configuration is complete, run the display vll ccc command to view information about the CCC connection on the PE. You can find that a local CCC connection is set up on the PE, and the connection status is Up.
    <PE> display vll ccc
    total  ccc vc : 1
    local  ccc vc : 1,  1 up
    remote ccc vc : 0,  0 up
    
    
    name: ce1-ce2, type: local, state: up,
    intf1: Pos1/0/0 (up),   intf2: Pos2/0/0 (up)
    VC last up time : 2008-07-24 12:31:31
    VC total up time: 0 days, 2 hours, 12 minutes, 51 seconds
    
    Run the display l2vpn ccc-interface vc-type ccc command, and you can find that the VC type is CCC and the status is Up.
    <PE> display l2vpn ccc-interface vc-type all
    
    
    Total ccc-interface of CCC : 2
    up (2), down (0)
    Interface                     Encap Type               State     VC Type
    Pos1/0/0                       ppp                      up        ccc
    Pos2/0/0                       ppp                      up        ccc    
    Run the display ip routing-table command on the CEs to check the interface routes learned on CE1 and CE2 from each other. CE1 and CE2 can successfully ping each other.
    Take CE1 as an example:
    <CE1> display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5        Routes : 5
    
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
    
          100.1.1.0/24  Direct 0    0           D  100.1.1.1       Pos1/0/0
          100.1.1.1/32  Direct 0    0           D  127.0.0.1       InLoopBack0
          100.1.1.2/32  Direct 0    0           D  100.1.1.2       Pos1/0/0
          127.0.0.0/8   Direct 0    0           D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0           D  127.0.0.1       InLoopBack0 
    <CE1> ping 100.1.1.2
      PING 100.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 100.1.1.2: bytes=56 Sequence=1 ttl=255 time=180 ms
        Reply from 100.1.1.2: bytes=56 Sequence=2 ttl=255 time=60 ms
        Reply from 100.1.1.2: bytes=56 Sequence=3 ttl=255 time=10 ms
        Reply from 100.1.1.2: bytes=56 Sequence=4 ttl=255 time=70 ms
        Reply from 100.1.1.2: bytes=56 Sequence=5 ttl=255 time=60 ms
      --- 100.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 10/76/180 ms


Configuration Files

  • Configuration file of CE1
    #
     sysname CE1
    #
    interface Pos1/0/0
     link-protocol ppp
     undo shutdown
     ip address 100.1.1.1 255.255.255.0
    #
    return
  • Configuration file of the PE
    #
     sysname PE
    #
     mpls lsr-id 1.1.1.9
     mpls
    #
     mpls l2vpn
    #
    interface Pos1/0/0
     link-protocol ppp
     undo shutdown
    #
    interface Pos2/0/0
     link-protocol ppp
     undo shutdown
    #
     ccc ce1-ce2 interface Pos1/0/0 out-interface Pos2/0/0
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    return
  • Configuration file of CE2
    #
     sysname CE2
    #
    interface Pos1/0/0
     link-protocol ppp
     undo shutdown
     ip address 100.1.1.2 255.255.255.0
    #
    return

No comments:

Post a Comment